KB25504: Summarize fails with error during the Traffic summary...

Expand / Collapse
 

KB25504: Summarize fails with error during the Traffic summary stage


Problem

Data Summarization fails.



Symptoms

When an automatic or manual summarize is executed, it will fail with the following error in the DataProcessor log file:

eError: 5/7/2009 3:55:12 PM Summarize - SummarizeSelectMedia: The process cannot access the file 'Node_011f635c-0bf9-48e0-9249-256aa2161429_TrafficData_20090103.txt' because it is being used by another process.
STACK: at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive)
at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive)
at prairieFyre.Traffic.DataReader.SummarizeTraffic.DeleteExistingBulkInsertFiles()
at prairieFyre.Traffic.DataReader.SummarizeTraffic..ctor(DateTime dtStartDate, DateTime dtEndDate)
at prairieFyre.BAL.DataAnalysis.Summarize.SummarizeSelectMedia(Guid[] mediaIDs, DateTime[] dates, Int32 ReplayStreamTimeNotificationIntervalSecs, SummarizeStatusUpdate OnSummarizeStatusUpdate, SummarizeProcessingCompleted



Cause

This is caused by an error in the Traffic summary engine.



Workaround

Disable Traffic Data collection for media servers.



Resolution

Download the following hotfix to the CCM Enterprise Server: KB25504
Double-click the .exe file and follow the instructions.

WARNING: Installing the hotfix will Stop and Start ALL prairieFyre services.
It is recommended to install the hotfix outside of regular business hours to avoid any potential service affecting issues.



Applies To

CCM version 5.5 SP2





Rate this Article:
     
Tags:

Add Your Comments


Name: *
Email Address:
Web Address:
Verification Code:
*
 

Details
Last Modified:Friday, January 21, 2011
Last Modified By: kmiddlemiss
Type: HOTFIX
Article not rated yet.
Article has been viewed 242 times.
Options