Article ID: 50927 - Last Review: September 2, 2010
PROBLEM
PhoneSet Manager controls take an excessively long time to load.
SYMPTOMS
Clicking OK in the Softphone configuration dialog to launch PhoneSet Manager takes several minutes, during which time the user has no control over the Contact Center Client.

CAUSE
Sorting the configured Account Codes and Account Code groups was not optimized when initializing Phone Set Manager.
WORKAROUND
Reduce the amount of Account Codes and Account Code groups. The customer that first reported this issue had configured over 4400 Account Codes.
RESOLUTION
Download the following hotfix to the CCM Enterprise Server: KB38804
Double-click the .exe file and follow the instructions.
WARNING: Installing the hotfix will Stop and Start ALL prairieFyre services.
It is recommended to install the hotfix outside of regular business hours to avoid any potential service affecting issues.
NOTE: Clients will require registry "Write" permissions in order to apply the update.
Due to export regulations, direct links to the hotfix associated with this Knowledge Base article is no longer provided through prairieFyre Software’s Knowledge Base and FTP server. Instead, you will have to login to www.mitel.com using your Mitel OnLine credentials to gain access to downloads.
To download this hotfix - Using a web browser browse to http://www.mitel.com.
- Click Login.
- Type your MOL User ID and Password and click Log in.
- Under Support click Software Downloads.
- To download
- A Contact Center Enterprise Edition hotfix, click Contact Center Enterprise Edition=>Contact Center Enterprise Edition Software Download and after Download the Mitel Networks Contact Center Enterprise Edition, click CCEE_FullRelease.
- A Contact Center Business Edition hotfix, click Contact Center Business Edition=>Contact Center Business Edition Software Download and after Download the Mitel Networks Contact Center Business Edition, click CCBE_FullRelease.
- A Call Accounting hotfix, click Call Accounting=>Call Accounting Software Download and after Download the Mitel Networks Call Accounting, click CA_FullRelease.
- Intelligent Queue Enterprise Edition software, click Contact Center Enterprise Edition=>Contact Center Enterprise Edition Software Download and after Download the Mitel Networks Contact Center Enterprise Edition.
- Intelligent Queue Business Edition software, click Contact Center Business Edition=>Contact Center Business Edition Software Download and after Download the Mitel Networks Contact Center Business Edition, click CCBE_FullRelease.
The Download Center opens.
- Click Installing Contact Center Solutions and Call Accounting hotfixes.
- In the list of available hotfixes, identify the hotfix you require using the number of this Knowledge Base article, and click the associated Web Download or FTP Download link.
APPLIES TO
CCM version 5.7 GA
Keywords: 38804 phoneset manager psm slow loading