Multimedia email messages not routing to agents

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Multimedia email messages not routing to agents


Article ID: 50928 - Last Review: September 2, 2010

PROBLEM

Multimedia email messages are not routing to agents.



SYMPTOMS

Multimedia messages will be ticketed and remain in the queue public folder, but will not route to agents.  Messages will not move to the repository.

The Windows Event Viewer on the prairieFyre exchange server may contain an error similar to the following:

An error occured while processing an Exchange object. The log file, C:\Program Files\prairieFyre Software Inc\CCM\Services\ExchangeRouter\Logs_6150Router\MCC Exchange Objects-Log-1.txt, may contain more details. Details of the error are listed below:
Exchange message ID: 0
Object URL: file://./backofficestorage/L-com.com/Public Folders/CyberAED/Queues/ArianneRivas/RE%3A Sales Acknowledgement #3268046 from ARIANNE PENA-RIVAS at L-com, Inc.-5441814.EML
Required action: CreateNewMessage
Error StackTrace: System.Runtime.InteropServices.COMException (0x800A0E94): Server cannot complete the operation.
at ADODB.RecordClass.CopyRecord(String Source, String Destination, String UserName, String Password, CopyRecordOptionsEnum Options, Boolean Async)
at prairieFyre.Exchange.ExchangeMailItem.CopyTo(String sDestURL)
at prairieFyre.Services.Message_New.ProcessNewMessage()
at prairieFyre.Services.Message_New.InternalProcess()
at prairieFyre.Services.Message_Base.Process()
at prairieFyre.Services.WorkItem.DoWork(Object state)


The Exchange Router log may contain the following error:

Error in initializing message ID : 5112986. Cannot find message in the repository - LEAVING MESSAGE ALONE. Original Queue URL: file://./backofficestorage/L-com.com/Public Folders/-FlatUrlSpace-/a51a594c1bae924e98edaba5f1aa0f2a-7e2ef4d/a51a594c1bae924e98edaba5f1aa0f2a-1c868d9b

The Enterprise log may contain the following warning:
eWarning 9/1/2010 10:50:55 AM EnterpriseServer MCC CallMgr - HandleExchangeFailure Message ID 5112892 is no more in the queue public folder. This message will be dequeued



CAUSE

The Repository folder has reached it's size limit.  The default public folder size is approximately 2GB.  The file size limit can also affect other functions such as replies not processing if the replies folder is at it's limit.  Calls will queue up and can be seen in the "Queue Now" monitor, but agents will remain idle.



WORKAROUND

Purge older messages from the repository folder.



RESOLUTION

Increase the size of the repository folder.  (Instructions below are for Exchange 2007)

  1. Open the Exchange Management Console (Start=>All Programs=>Microsoft Exchange Server 2007=>Exchange Management Console)

  2. Select Toolbox and double-click Public Folder Management Console

  3. Expand the Default Public Folders and click CyberAED

  4. Click Properties on the Employees Action menu

  5. Select the Limits tab
  6. Under Storage quotas, increase the Maximum size (KB) value to a higher number

  7. You can also just check Use database quota defaults instead of limiting the size
  8. Click OK


APPLIES TO

Multimedia Contact Center versions

Keywords: mcc emails not routing



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Details
Last Modified:Thursday, September 02, 2010
Last Modified By: ademski
Type: FIX
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