KB32508: Inaccurate Queue Now real time data for conference calls (5.5 SP3)


Problem

Several SMDR records for a conference calls are mixed together and so the conference stats are inaccurate.  The problem is that it cannot keep updating the real time queue now monitor and getting accurate conference call reports after maintenance/manual summarize.



Symptoms

The Queue Now monitor does not update calls that have "C" conference tag in the SMDR record.

Example SMDR record:

07/23 13:09:17  0000:00:31 640     0011 P151 120 120              I 782            C T105                 1



Cause

The registry setting "ProcessConferenceRecordsInLifeCycle" is used to credit conference calls in the Life Cycle component based on the corresponding ACD records to get proper call duration for each devices involved in the conference call.  However, this logic requires to process all conference SMDR records after the call is fully completed and so it will not update the real time queue now monitor with the conference call.



Workaround

None.



Resolution

Download the following hotfix to the CCM Enterprise Server: KB32508
Double-click the .exe file and follow the instructions.

WARNING: Installing the hotfix will Stop and Start ALL prairieFyre services.
It is recommended to install the hotfix outside of regular business hours to avoid any potential service affecting issues.

You must add the following registry key after the hotfix is installed in order to ignore the "ProcessConferenceRecordsInLifeCycle" key:

Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\prairieFyre Software Inc\CCM\Common
Registry Value Name: IgnoreProcessConferenceRecordsInLifeCycleDuringRealTime
Registry Value Type: REG_SZ
Registry Value: 1 to ignore "ProcessConferenceRecordsInLifeCycle", 0 to keep "ProcessConferenceRecordsInLifeCycle".



Applies To

CCM v5.5 SP3




Posted Monday, June 21, 2010 by ademski
http://www.prairiefyre.com/kb/KnowledgebaseArticle50790.aspx