KB36389: MiTAI reporting domain Internal for External CallReceived events - Incorrect caller ID (ANI) in real time


Problem

Functionality relying on correctly interpreted MiTAI CallReceived records (e.g. Caller ID), is seeing the caller domain set as Internal when it should in fact be External.

This is causing the MiTAI Call Linker to skip over the ANI (and potentially DNIS) information in these records in a transferred call scenario which leaves the Caller ID showing as the DN of the transferring device.



Symptoms

In the Contact Center Client Agent State by Time monitor, the incorrect caller ID (ANI) may be seen or no caller ID may be seen at all when an agent answers an ACD call.



Cause

The SDK4 MiTAI header file was used to rebuild the SDK3 version of the PFMiTAIConnector DLL.  Note that this only affects customers configured to use MiTAI SDK 3.



Workaround

Set the "Enable Agent Group Presence" checkbox to ensure that MiTAI SDK 4 is loaded.

  1. Open the CCMWeb
  2. Select YourSite=>Enterprise
  3. Check the box beside "Enable Agent Group Presence and/or Personal Identification Number (PIN) functionality"
  4. Click Save


Resolution

Download the following hotfix to the CCM Enterprise Server: KB36389
Double-click the .exe file and follow the instructions.

NOTE: You must install KB34714 as a prerequisite before installing the above hotfix.  Click the following link for more information about KB34714: KnowledgebaseArticle50678

WARNING: Installing the hotfix will Stop and Start ALL prairieFyre services.
It is recommended to install the hotfix outside of regular business hours to avoid any potential service affecting issues. 



Applies To

CCM version 5.7 GA




Posted Wednesday, July 28, 2010 by ademski
http://www.prairiefyre.com/kb/KnowledgebaseArticle50886.aspx